Avoid These 3 Things or Your WordPress Site Will Get Infected

Posted on Feb 13, 2020


Avoid These 3 Things or Your WordPress Site Will Get Infected

Do Not Do These Things or Your WordPress Site Will Get Infected

There are some very common and simple mistakes that you can make when working with WordPress that can cause your site to be vulnerable or cause the hosting environment in which your website resides to be vulnerable. We want to highlight the three main things that many people do that we see often and we want to educate those that read this. Simply staying away from these very common actions that people incorporate into their WordPress experience will ensure that you are protecting your site from many vulnerabilities that exist out there and this will allow you to stay away from your WordPress site getting infected.

Before we start diving in to these three common things to avoid let’s talk about the myth out there that WordPress is not a secure platform. This statement is completely false. WordPress at its very core is a very safe and stable platform to use in making all of your web dreams come true. What makes it unsafe is all of the extra plugins and third party themes that we use on our site. Many of these plugins and themes can contain vulnerabilities that will allow infectious codes to be injected into our website files and database.

But where would we all be without plugins and these fancy pre-designed themes that exist? Many of us would just be pulling our hair out trying to design a website and make it function the way that we want if we were not able to use plugins and custom themes. The good news is as long as we take certain security measures we can go on using any plugins and themes that we desire without the fear of getting infected.

So let us dive in now and provide you with the three most common things that WordPress users do that will almost surely guarantee to make your website vulnerable and lead you into an infected situation where you now have malicious activity on your website.


Avoid These 3 Things or Your WordPress Site Will Get Infected

#1 Run An Out Dated Version of PHP & Your WordPress Site Will Get Infected

WordPress is one of the broadly utilized stages over the globe. One reason behind its ubiquity is open-source nature. Be that as it may, what makes WordPress an open-source stage? Indeed, the response to that would be PHP. WordPress runs on PHP which is a scripting language adding to around 83% of the considerable number of sites!

Avoid These 3 Things or Your WordPress Site Will Get Infected


The above diagram shows the consequence of the bench-marking test. The pattern shows steady improvement in dealing with demands every seconds from PHP variant 5.6 to 7.3. As indicated by this outcome, PHP 7.3 is a conspicuous champ while 7.2 was somewhat behind.

This consequence of this WordPress execution test likewise shows the similarity among PHP and WordPress and the steady improvement it brings to your WordPress site. By taking a gander at the outcomes, WordPressers can undoubtedly comprehend the significance of refreshed PHP variant. For example, if a site is as of now introduced on PHP 5.6 or 7.0, I enthusiastically prescribe redesigning it to the most recent PHP rendition.

Take a look at a very detailed article below that will break down the difference is between the most recent versions of PHP and how they affect the performance of your WordPress site.
https://www.cloudways.com/blog/wordpress-performance-on-php-versions

Is PHP Version 5 going to be EOL soon?

For those of you that are not familiar with what EOL means it is an acronym for end of life.

Truly. PHP form 5 will be announced End-Of-Life on January first, 2019. That is, in roughly two months at the hour of composing.

The PHP improvement group’s approach with respect to end-of-life is as per the following: each arrival of PHP is completely bolstered for a long time from the date of discharge. At that point it is upheld for an extra year for basic security gives as it were. When three years has slipped by from the date of discharge, the adaptation of PHP is never again upheld.

PHP 7.0, the absolute first PHP 7 discharge, was discharged on 3 December, 2015, right around three years back. PHP form 5 is quickly moving toward end-of-life and will never again be upheld beginning on 1 January, 2019.

The last part of PHP adaptation 5 that is as yet upheld is PHP 5.6. Since this is the last PHP 5 branch, the PHP group decided to expand the security fix period from the standard one years, to two years. That all-inclusive security bolster will end on 1 January 2019.

The accompanying table incorporates the significant dates for PHP 5 and PHP 7 branches.

Avoid These 3 Things or Your WordPress Site Will Get Infected

Does PHP 5 have any vulnerabilities?

Security vulnerabilities are constantly detailed in PHP. A portion of these are not kidding. Survey this page on CVEDetails.com will give you a thought of the volume and seriousness of PHP vulnerabilities that have as of late been accounted for.

A significant number of the vulnerabilities revealed in PHP were found for the current year. A lot more will be found in PHP form 5 one year from now, after security support for all renditions of PHP 5 have finished. That is the reason it is basically significant that you move up to a variant of PHP 7 that is upheld and is accepting security refreshes.

How can I find out my PHP version?
There are a few different ways that you can find out this information. A very simple way would be to Simply contact your hosting company and ask them directly. If you do not want to go through the trouble of contacting them you can use the plugin at the link below to display the PHP version that you are using on your website.
https://wordpress.org/plugins/display-php-version

So what is the top and bottom of this PHP upgrade topic?
So just to summarize here, you need to ensure that your WordPress site is running the most recent version of PHP. Doing this will limit your vulnerabilities two attacks. It also will make sure that your site is functioning at Optimal Performance when it comes to PHP.


Avoid These 3 Things or Your WordPress Site Will Get Infected

#2 Ignore Your Software Updates & YOur WordPress Site Will Get Infected

One of the worst things that you can do in the management of your WordPress site is to ignore your software updates. Your software updates are the updates that are pending for any plugins that are installed on your website, any themes (best practice here is to only have you’re active theme installed) that are installed on your website and your WordPress core installation.

These updates are extremely important. Many of these updates contain bug fixes to security vulnerabilities. Also the majority of these updates also help to improve the functionality of your website. It is a really bad practice to ignore these updates. Just imagine if you will the engine light in your car. When this light is on it is notifying you that there is something wrong with your engine that needs to be addressed. You need to start thinking about your WordPress updates the same way that you would with the engine light in your car. When you see that bubble with pending updates inside of your WordPress administrative area, you need to take action. Not doing so could result in creating vulnerabilities in your website.

How every now and again are WordPress module refreshes discharged?

It is anything but a simple inquiry to answer in light of the fact that there’s no freely accessible memorable data-set to break down. Does it mean we can’t get any knowledge on this subject? I state: “Heck, no!”

There’s an official site from which we can gather discharge dates data: the (all-powerful) WordPress Repository. In my exploration for a normal time range for module refreshes, I took a gander at the most recent discharge dates for the entirety of the 1386 WordPress modules marked as “Mainstream” on the WordPress vault:

Avoid These 3 Things or Your WordPress Site Will Get Infected


This bar outline shows what number of mainstream WordPress modules and the time they’ve been formally last refreshed (as of the hour of this composition).

Fascinating, uh? That is to say, it sure is uncovering seeing that there are 300+ modules assembled under the “well known” classification which haven’t been refreshed in over a year. Be that as it may, that is another story, one that may see a fix in the near future-ish.

For the purpose for this conversation, how about we concur that modules which have been refreshed over a year back and not exactly seven days prior have either reasons hard to distinguish or have to do with coincidental realities (like the time and day I checked the plugin repo). Consequently, we should expel this information from the condition for a minute, and let center around modules which have been refreshed in under 1 year and not in the most recent week.

So how important is it really to complete your updates?
It isn’t extremely important to make sure that all of the software that your website is using is up-to-date. Now just saying that may not be enough because we haven’t explained in detail how to complete each update. Take a look at the link below for a extensive explanation of how to complete all of the updates on your site safely and properly.
https://www.wpexplorer.com/quick-guide-updating-wordpress


Avoid These 3 Things or Your WordPress Site Will Get Infected

#3 Using Weak Login Information & Your WordPress Site Will Get Infected

We really hope that the username and password to login to your WordPress administrative area is not “admin”! Now those of you that do not have your login information set up like this are probably laughing and thinking that no one would be so silly to have their username be “admin” and their password be “admin” as well.  Then there are others that are reading this that have exactly that and are cringing a bit because they were unaware that this is a bad idea. We see it all the time here. Very weak login information can be an easy way for hackers to attack and inject your website.

For each record you set up you should utilize a novel and troublesome secret phrase. That is guaranteed, however you’d be astonished at what number of individuals don’t give a second however to secret word security.

This implies, as a rule, the most secure methodology is to not surrender secret word wellbeing over to your clients. Rather, you can authorize the utilization of solid passwords over all your WordPress site clients. This is a basic method to improve the security of your WordPress site.

Right now going to discuss the basics of secret key security and WordPress secret word security . At that point we’ll examine why it is anything but a smart thought to confide in your clients to concoct solid passwords all alone, and disclose how to authorize your own secret phrase strategies utilizing a WordPress module. We should find a workable pace!

What Makes for a Secure Password?

You’ve most likely heard a lot of guidance about how to make solid passwords. Previously, the normal shrewdness concentrated on utilizing complex blends of characters, for example, “sd8f!¿$”?”.

That is not an awful secret word, yet nowadays we realize that length is the principle donor with regards to secret key security. Long passwords are more earnestly to figure and to break. The issue, obviously, is that they’re additionally harder to recall.

Luckily, there are a lot of brilliant secret phrase directors out there. You can utilize them to create, store, and naturally enter your login data anyplace on the web. All things considered, investigate gives us that the vast majority don’t pay attention to secret word security (more on this quickly).

That represents an issue in case you’re running a WordPress site that has visitor creators, editors, clients or clients. All things considered, it’s your obligation to give a sheltered situation to your clients, regardless of whether they don’t use sound judgment when left to their own gadgets.

1. The vast majority Use Terribly Weak Passwords

In case you’re understanding this, you presumably put probably some idea into your passwords. That as of now places you in the top percentile among web clients. To give you a thought of how terrible things despite everything are, here are the main five most basic passwords on the web as indicated by Wikipedia:

  • 123456
  • secret key
  • 123456789
  • 12345678
  • 12345

On the off chance that you find that rundown difficult to accept, you’re not the only one. Those passwords are on the whole excessively short, exceptionally simple to figure, and out and out senseless. With such poor decisions being a great many people’s default, it’s no big surprise there are such huge numbers of online record breaks each day. On the off chance that a supervisor or manager on your WordPress business site utilizes a comparable secret key, it will just take a couple of moments to break their secret phrase during an animal power assault.

3. Individuals Tend to Reuse Passwords for Multiple Accounts

One regular issue in web security is that even individuals who do utilize solid passwords frequently reuse them for some records. That represents an issue, in light of the fact that regardless of how solid a secret word may be, in the event that one of the sites you use it on is hacked and aggressors gain admittance to it, they can likewise pick up passage to all your different records.

As we brought up before, recalling many long novel passwords can be very troublesome. That is the place secret key directors indeed act the hero. Regardless of whether it takes somewhat more, it’s indispensable to make a one of a kind secret key for each online record you have.

The most effective method to Enforce Strong Password Use in WordPress

Now, we’ve ideally clarified how horrendous individuals are with passwords when all is said in done. The genuine inquiry is: what can be done?

For one, you ought to teach your clients about savvy secret key decisions. Make them mindful about social building assaults, and the negative effect on the business frail passwords can have. A ton of locales attempt to do this during the sign-up process. Be that as it may, it likewise pays to be reasonable. This implies understanding that many individuals won’t follow great practices except if you constrain them to.

As a matter of course, WordPress cautions you in case you’re setting a powerless secret key. In any case, clients can generally overlook the admonition and still utilize a feeble secret phrase. So as a WordPress site administrator you need to go above and beyond. Utilizing the privilege module, you can drive your WordPress clients to utilize solid passwords with our own Password Policy Manager for WordPress module:

  • set a minimum length for all passwords
  • enforce rules about what types of characters, numbers and case should be used
  • set passwords to  expire (always a good move, otherwise people will use the same password for years)
  • configure password policies per WordPress user role
  • and much more!

Solid Passwords as an Essential Part of Website Security

Probably the most effortless approaches to verify your records and online information is to utilize solid, novel passwords (and empowering two-factor validation whenever the situation allows). Recollecting different long passwords is never again a reason. Nowadays there are a lot of apparatuses, a.k.a secret phrase chiefs that you should use to store qualifications safely.

In case you’re an executive of a WordPress site yourself, instruct the clients about keen secret phrase decisions. Be that as it may, it’s far more secure to authorize the utilization of secure passwords. In WordPress, you can do this effectively utilizing the Password Policy Manager module. All things considered, clients should be prepared and guided to utilize secure passwords.


In Conclusion

If you take notice to the three things that we talked about in this article and make sure that you stay far away from ever falling into a trap of having one of these exist in your WordPress environment. If you have any questions about anything that we’ve talked about here please comment below and happy WordPress-ing.

The post Avoid These 3 Things or Your WordPress Site Will Get Infected appeared first on WP Fix It.


Skip to content